Understanding the New OpenSSL MiTM Vulnerability

An attacker using a carefully crafted handshake can force the use of weak keying material in OpenSSL SSL/TLS clients and servers. This can be exploited by a Man-in-the-middle (MITM) attack where the attacker can decrypt and modify traffic from the attacked client and server.

The attack can only be performed between a vulnerable client and server. OpenSSL clients are vulnerable in all versions of OpenSSL. Servers are only known to be vulnerable in OpenSSL 1.0.1 and 1.0.2-beta1. Users of OpenSSL servers earlier than 1.0.1 are advised to upgrade as a precaution.

Like Heartbleed, the flaw has to do with the implementation of cryptography methods within OpenSSL. Unlike Heartbleed though, the new flaw will likely have a limited scope because the attack can only be performed if the perpetrator has access to both a vulnerable client and a vulnerable server.

Fortunately, in light of these recent vulnerabilities, OpenSSL will be getting two more dedicated developers, more funding, and a full security audit.

What should server administrators do?

Although the new vulnerabilities in OpenSSL may not necessarily need to be patched today, they should be addressed in the next few days as vendors make it known if their products are impacted.

OpenSSL 0.9.8 SSL/TLS users (client and/or server) should upgrade to 0.9.8za.
OpenSSL 1.0.0 SSL/TLS users (client and/or server) should upgrade to 1.0.0m.
OpenSSL 1.0.1 SSL/TLS users (client and/or server) should upgrade to 1.0.1h.

Robert Valcourt
Jun 12, 2014
By
Understanding the New OpenSSL MiTM Vulnerability

Get Email Updates (It's FREE)

We respect your privacy!

Made With In Whistler